package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\s\S]*?<p>([^<>]*?)<\/p>`)
var str = `<h1>I don't want the title</h1>
<p>This is the text I want</p>
<p>I don't want this</p>
<p>I also don't want this</p>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}