$re = '/^[\s\S]*?<p>([^<>]*?)<\/p>/';
$str = '<h1>I don\'t want the title</h1>
<p>This is the text I want</p>
<p>I don\'t want this</p>
<p>I also don\'t want this</p>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);