use strict;
my $str = '<h1>I don\'t want the title</h1>
<p>This is the text I want</p>
<p>I don\'t want this</p>
<p>I also don\'t want this</p>';
my $regex = qr/^[\s\S]*?<p>([^<>]*?)<\/p>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}