using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(<table>.*?<\/table>)";
string input = @"<div>
<table>1<table>
<table>2</table>
<table>3</table> - i need this one and all its contents
<div>";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}