re = /.*(<table>.*?<\/table>)/
str = '<div>
<table>1<table>
<table>2</table>
<table>3</table> - i need this one and all its contents
<div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end