const regex = /.*(<table>.*?<\/table>)/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(<table>.*?<\\\/table>)', 's')
const str = `<div>
<table>1<table>
<table>2</table>
<table>3</table> - i need this one and all its contents
<div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}