using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\/)\b([^\/ ]+)\/([^\/ ]+)\b(?!\/)";
string substitution = @"$1\\ \/$2";
string input = @"""/* something */ example/123 anotherexample123/456 url/link/to/somewhere """;
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}