$re = '/(?<!\/)\b([^\/ ]+)\/([^\/ ]+)\b(?!\/)/m';
$str = '"/* something */ example/123 anotherexample123/456 url/link/to/somewhere "';
$subst = "$1\\ \/$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;