const regex = /(?<!\/)\b([^\/ ]+)\/([^\/ ]+)\b(?!\/)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\\/)\\b([^\\\/ ]+)\\\/([^\\\/ ]+)\\b(?!\\\/)', 'mg')
const str = `"/* something */ example/123 anotherexample123/456 url/link/to/somewhere "`;
const subst = `$1\\ \/$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);