import re
regex = re.compile(r"(?<!\/)\b([^\/ ]+)\/([^\/ ]+)\b(?!\/)", flags=re.MULTILINE)
test_str = "\"/* something */ example/123 anotherexample123/456 url/link/to/somewhere \""
subst = "$1\\\\ \\/$2"
result = regex.sub(subst, test_str)
if result:
print(result)