# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[\s\S]*(?:^|\r?\n)\s*(\d+)(?![\s\S]*(\r?\n){2})/$1/m;t' <<< "this is test
1. this is test
2. this is test
3. this is test
this is test
1. this test
2. this is test
this is test"