#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[\s\S]*(?:^|\r?\n)\s*(\d+)(?![\s\S]*(\r?\n){2})"
Local $sString = "this is test" & @CRLF & _
" 1. this is test" & @CRLF & _
" 2. this is test" & @CRLF & _
" 3. this is test" & @CRLF & _
"this is test" & @CRLF & _
" 1. this test " & @CRLF & _
" 2. this is test" & @CRLF & _
"this is test"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)