use strict;
my $str = 'this is test
1. this is test
2. this is test
3. this is test
this is test
1. this test
2. this is test
this is test';
my $regex = qr/^[\s\S]*(?:^|\r?\n)\s*(\d+)(?![\s\S]*(\r?\n){2})/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";