const regex = /^[\s\S]*(?:^|\r?\n)\s*(\d+)(?![\s\S]*(\r?\n){2})/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\s\\S]*(?:^|\\r?\\n)\\s*(\\d+)(?![\\s\\S]*(\\r?\\n){2})', 'm')
const str = `this is test
1. this is test
2. this is test
3. this is test
this is test
1. this test
2. this is test
this is test`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);