$re = '/^[\s\S]*(?:^|\r?\n)\s*(\d+)(?![\s\S]*(\r?\n){2})/m';
$str = 'this is test
1. this is test
2. this is test
3. this is test
this is test
1. this test
2. this is test
this is test';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;