#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*_duplicate_(?!00[1-2])\d{3}\.txt"
Local $sString = "./prefix_duplicate_001.txt " & @CRLF & _
"./prefix_duplicate_002.txt " & @CRLF & _
"./prefix_duplicate_003.txt " & @CRLF & _
"./prefix_duplicate_004.txt " & @CRLF & _
"./prefix_duplicate_005.txt" & @CRLF & _
"./prefix_duplicate_100.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")