re = /.*_duplicate_(?!00[1-2])\d{3}\.txt/m
str = './prefix_duplicate_001.txt
./prefix_duplicate_002.txt
./prefix_duplicate_003.txt
./prefix_duplicate_004.txt
./prefix_duplicate_005.txt
./prefix_duplicate_100.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end