const regex = /.*_duplicate_(?!00[1-2])\d{3}\.txt/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*_duplicate_(?!00[1-2])\\d{3}\\.txt', 'mg')
const str = `./prefix_duplicate_001.txt
./prefix_duplicate_002.txt
./prefix_duplicate_003.txt
./prefix_duplicate_004.txt
./prefix_duplicate_005.txt
./prefix_duplicate_100.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}