import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*_duplicate_(?!00[1-2])\\d{3}\\.txt";
final String string = "./prefix_duplicate_001.txt \n"
+ "./prefix_duplicate_002.txt \n"
+ "./prefix_duplicate_003.txt \n"
+ "./prefix_duplicate_004.txt \n"
+ "./prefix_duplicate_005.txt\n"
+ "./prefix_duplicate_100.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}