#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "-?(?:\d+(?:\.\d*)?|\.\d+)"
Local $sString = "-1234454.3435" & @CRLF & _
"-98.99" & @CRLF & _
"-12.9" & @CRLF & _
"-12.34" & @CRLF & _
"-10.001" & @CRLF & _
"-3" & @CRLF & _
"-0.001" & @CRLF & _
"-000" & @CRLF & _
"-0.00" & @CRLF & _
"0" & @CRLF & _
"0.00" & @CRLF & _
"00000001.1" & @CRLF & _
"0.01" & @CRLF & _
"1201.0000001" & @CRLF & _
"1234454.3435" & @CRLF & _
"7638.98701"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")