re = /-?(?:\d+(?:\.\d*)?|\.\d+)/
str = '-1234454.3435
-98.99
-12.9
-12.34
-10.001
-3
-0.001
-000
-0.00
0
0.00
00000001.1
0.01
1201.0000001
1234454.3435
7638.98701'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end