import re
regex = re.compile(r"-?(?:\d+(?:\.\d*)?|\.\d+)")
test_str = ("-1234454.3435\n"
"-98.99\n"
"-12.9\n"
"-12.34\n"
"-10.001\n"
"-3\n"
"-0.001\n"
"-000\n"
"-0.00\n"
"0\n"
"0.00\n"
"00000001.1\n"
"0.01\n"
"1201.0000001\n"
"1234454.3435\n"
"7638.98701")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")