import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-?(?:\\d+(?:\\.\\d*)?|\\.\\d+)";
final String string = "-1234454.3435\n"
+ "-98.99\n"
+ "-12.9\n"
+ "-12.34\n"
+ "-10.001\n"
+ "-3\n"
+ "-0.001\n"
+ "-000\n"
+ "-0.00\n"
+ "0\n"
+ "0.00\n"
+ "00000001.1\n"
+ "0.01\n"
+ "1201.0000001\n"
+ "1234454.3435\n"
+ "7638.98701";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}