using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![0-9]+$)[A-Za-z0-9_-]{10,30}$";
string input = @"1eeeeeeeee333e
eeeeeeeee333e
1111111111111
62222222252242
123456789012q";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}