const regex = /^(?![0-9]+$)[A-Za-z0-9_-]{10,30}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![0-9]+$)[A-Za-z0-9_-]{10,30}$', 'gm')
const str = `1eeeeeeeee333e
eeeeeeeee333e
1111111111111
62222222252242
123456789012q`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}