import re
regex = re.compile(r"^(?![0-9]+$)[A-Za-z0-9_-]{10,30}$", flags=re.MULTILINE)
test_str = ("1eeeeeeeee333e\n"
"eeeeeeeee333e\n"
"1111111111111\n"
"62222222252242\n"
"123456789012q")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")