$re = '/^(?![0-9]+$)[A-Za-z0-9_-]{10,30}$/m';
$str = '1eeeeeeeee333e
eeeeeeeee333e
1111111111111
62222222252242
123456789012q';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);