import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![0-9]+$)[A-Za-z0-9_-]{10,30}$";
final String string = "1eeeeeeeee333e\n"
+ "eeeeeeeee333e\n"
+ "1111111111111\n"
+ "62222222252242\n"
+ "123456789012q";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}