package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\\\(\d+)\s+[\d\\]+$`)
var str = `\\0101 \\0102 \\0103 \\0104
\\0201 \\0202 \\0203 \\0204 \\0205 \\0206
\\0301 \\0302 \\0303 \\0304 \\0305 \\0306`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}