use strict;
my $str = '\\\\0101 \\\\0102 \\\\0103 \\\\0104
\\\\0201 \\\\0202 \\\\0203 \\\\0204 \\\\0205 \\\\0206
\\\\0301 \\\\0302 \\\\0303 \\\\0304 \\\\0305 \\\\0306';
my $regex = qr/\\\\(\d+)\s+[\d\\]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}