// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\\\(\d+)\s+[\d\\]+$").unwrap();
let string = "\\\\0101 \\\\0102 \\\\0103 \\\\0104
\\\\0201 \\\\0202 \\\\0203 \\\\0204 \\\\0205 \\\\0206
\\\\0301 \\\\0302 \\\\0303 \\\\0304 \\\\0305 \\\\0306";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}