import re
regex = re.compile(r"\\\\(\d+)\s+[\d\\]+$", flags=re.MULTILINE)
test_str = ("\\\\0101 \\\\0102 \\\\0103 \\\\0104\n"
"\\\\0201 \\\\0202 \\\\0203 \\\\0204 \\\\0205 \\\\0206\n"
"\\\\0301 \\\\0302 \\\\0303 \\\\0304 \\\\0305 \\\\0306")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")