using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @";[^;.]*;";
string substitution = @"";
string input = @"Lorem ipsum dolor sit amet, consectetur adipiscing elit. Donec eget eros
libero. Duis ac diam pretium velit volutpat facilisis in vel nibh. In lacinia ; neque
massa, in consectetur lectus ; faucibus vel. Maecenas ; dapibus leo nec ; elit sagittis
convallis. Sed at lacus consectetur, eleifend urna tristique, consequat orci. Nullam
ac orci quis elit pellentesque consectetur quis ac libero. Duis lorem sem, sodales ; ut
massa sed, porta facilisis ex. Aliquam cursus accumsan ante sed maximus. ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}