import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ";[^;.]*;";
final String string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Donec eget eros\n"
+ "libero. Duis ac diam pretium velit volutpat facilisis in vel nibh. In lacinia ; neque \n"
+ "massa, in consectetur lectus ; faucibus vel. Maecenas ; dapibus leo nec ; elit sagittis \n"
+ "convallis. Sed at lacus consectetur, eleifend urna tristique, consequat orci. Nullam \n"
+ "ac orci quis elit pellentesque consectetur quis ac libero. Duis lorem sem, sodales ; ut \n"
+ "massa sed, porta facilisis ex. Aliquam cursus accumsan ante sed maximus. ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}