#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)<table>.*?chair.*?</table>"
Local $sString = "<table>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" table" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
"</table>" & @CRLF & _
"<table>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" chair" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
"</table>" & @CRLF & _
"<table>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" door" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
"</table>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)