const regex = new RegExp('<table>.*?chair.*?</table>', 's')
const str = `<table>
<tr>
<td>
table
</td>
</tr>
</table>
<table>
<tr>
<td>
chair
</td>
</tr>
</table>
<table>
<tr>
<td>
door
</td>
</tr>
</table>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);