// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<table>.*?chair.*?</table>").unwrap();
let string = "<table>
<tr>
<td>
table
</td>
</tr>
</table>
<table>
<tr>
<td>
chair
</td>
</tr>
</table>
<table>
<tr>
<td>
door
</td>
</tr>
</table>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}