import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<table>.*?chair.*?</table>";
final String string = "<table>\n"
+ " <tr>\n"
+ " <td>\n"
+ " table\n"
+ " </td>\n"
+ " </tr>\n"
+ "</table>\n"
+ "<table>\n"
+ " <tr>\n"
+ " <td>\n"
+ " chair\n"
+ " </td>\n"
+ " </tr>\n"
+ "</table>\n"
+ "<table>\n"
+ " <tr>\n"
+ " <td>\n"
+ " door\n"
+ " </td>\n"
+ " </tr>\n"
+ "</table>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}