$re = '~<table>.*?chair.*?</table>~s';
$str = '<table>
<tr>
<td>
table
</td>
</tr>
</table>
<table>
<tr>
<td>
chair
</td>
</tr>
</table>
<table>
<tr>
<td>
door
</td>
</tr>
</table>';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;