#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^[\]]+\](?=[^[\]]*$)"
Local $sString = "jform[params][aaaaa][cccc]"
Local $sSubst = "bbbbb"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)