using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^[\]]+\](?=[^[\]]*$)";
string substitution = @"bbbbb";
string input = @"jform[params][aaaaa][cccc]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}