re = /[^[\]]+\](?=[^[\]]*$)/
str = 'jform[params][aaaaa][cccc]'
subst = 'bbbbb'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result