import Foundation
let pattern = #"[^[\]]+\](?=[^[\]]*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"jform[params][aaaaa][cccc]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"bbbbb"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)