import re
regex = re.compile(r"[^[\]]+\](?=[^[\]]*$)")
test_str = "jform[params][aaaaa][cccc]"
subst = "bbbbb"
result = regex.sub(subst, test_str)
if result:
print(result)