import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Action by .*\\, (.*)\\. (?<team1>.*)( \\d+\\,) (?<team2>.*)(\\d+\\.)";
final String string = "Action by Toni Kroos, Real Madrid. Rayo Vallecano 2, Real Madrid 0.\n"
+ "Action by Toni Kroos, Real Madrid. Real Madrid 0, Rayo Vallecano 2.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}