$re = '/^Action by .*\, (.*)\. (?<team1>.*)( \d+\,) (?<team2>.*)(\d+\.)/m';
$str = 'Action by Toni Kroos, Real Madrid. Rayo Vallecano 2, Real Madrid 0.
Action by Toni Kroos, Real Madrid. Real Madrid 0, Rayo Vallecano 2.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);