re = /^Action by .*\, (.*)\. (?<team1>.*)( \d+\,) (?<team2>.*)(\d+\.)/m
str = 'Action by Toni Kroos, Real Madrid. Rayo Vallecano 2, Real Madrid 0.
Action by Toni Kroos, Real Madrid. Real Madrid 0, Rayo Vallecano 2.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end