import re
regex = re.compile(r"^Action by .*\, (.*)\. (?<team1>.*)( \d+\,) (?<team2>.*)(\d+\.)", flags=re.MULTILINE)
test_str = ("Action by Toni Kroos, Real Madrid. Rayo Vallecano 2, Real Madrid 0.\n"
"Action by Toni Kroos, Real Madrid. Real Madrid 0, Rayo Vallecano 2.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")