using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\(\s*?[""']([^""']+?)[""']\s*?\)\.live\(\s*?[""']([^""']+?)[""'][^\(]+?\(";
string substitution = @"$(document.body).on(""$2"", ""$1"", function(";
string input = @"$("".delete_package"").live(""click"", function() {
// this is a test
}
$("".add_package"").live( ""mouseout"", function(e) {
// this is a test
}
$( "".ccc_package"" ).live( ""mouseover"", function(e, x) {
// this is a with var e + x
}
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}