import Foundation
let pattern = #"\$\(\s*?["']([^"']+?)["']\s*?\)\.live\(\s*?["']([^"']+?)["'][^\(]+?\("#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$(".delete_package").live("click", function() {
// this is a test
}
$(".add_package").live( "mouseout", function(e) {
// this is a test
}
$( ".ccc_package" ).live( "mouseover", function(e, x) {
// this is a with var e + x
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$(document.body).on("$2", "$1", function("#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)